FIXED Whirlpool WSF26C2EXF01 Door Icemaker Not Working

Gdurham

Premium Member
Joined
May 6, 2018
Messages
2
Location
Ca
Model Number
WSF26C2EXF01
Brand
Whirlpool
Age
1-5 years
Hello all, Would love some assistance troubleshooting an icemaker that isn't making ice. I have done the following:

I came across the icemaker with ice in the tray.
Attempted to jumper H and T, did not cause it to cycle.
I tested with power off to the fridge, the resistance on the points mentioned in documentation. Everything came back normal.
I followed the instructions posted to this forum: appliancejunk.com/forums/index.php?topic=18851.0


On step 25 in the on screen diag:
9V ac between L and N
0V ac when T and H are jumpered

When not on diag screen:
19V ac between L and N
19V ac when T and H are jumpered

Went to the main control board and checked between P1-1 and P3-3 (black and black white): 70V ac

I tested the IR, got 14V at pins 1 and 3, and tested via diagnostics by manually operating the flapper for the ice bin being installed. It appears to be working correctly as it returned the correct status.

The voltages feel strange to me, since all of the manuals say I should get 120V ac everywhere, am I doing somethign wrong here? What else should I be looking at?

I have also attempted to replace the motor module with no change.

I see that my refrigerator is affected by the tech bulletin in: W10787876A

Would that be the root of all of my issues? Anything I can do to confirm this?

Thank you.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,930
Location
McMullen Valley, Arizona
Ahhh, I think I know why the voltages are weird.

Another member was having a similar problem here: FIXED: GSF26C4EXY02 Whirlpool Gold Ice Maker Problem

Look at his post #6 he found frayed and broken wires underneath the freezer door, I'd remove your kickplate and check for that first.

Here's another one with the same thing about the frayed and broken wires: FIXED: 106.51173310 Kenmore elite ice maker not working - no led light

Here's the ice maker for your model:
WPW10251076 Icemaker


Let us know what you find.

Jake
 

Gdurham

Premium Member
Joined
May 6, 2018
Messages
2
Location
Ca
Hey Jake,
I think you nailed it, I looked at the wire loom, and can see some copper wire shining through. Is it okay to simply cut the wire loom and solder/heat shrink the damaged wires? Should i tape the wireloom back together after repairing it, or is there a better way to keep the loom intact?

Thanks!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
99,930
Location
McMullen Valley, Arizona
Excellent, good find.:)

Yes, solder them back together, then use heatsink over it when you are done soldering, like ljsmith1 did:

Here is what I found when I pulled off the harness protection:
FREEZER DOOR - b4.jpg

Here is the repair before I retaped and put back the harness protection:
Freezer Door - Repaired.jpg

Soldered the connections and used some marine-grade heat shrink.

Double checked everything with continuity meter, all good! Put it all back together and hopefully things will work!
Jake
 
Top