FIXED WRS588FIHZ00 Whirlpool Refrigerator - Ice maker not producing ice

Dyablo

Premium Member
Joined
Apr 7, 2019
Messages
7
Location
Buckeye, Az
Model Number
WRS588FIHZ00
Brand
Whirlpool
Age
1-5 years
About 3 days ago i noticed no new ice were being made. There are ice cubes in tray but it won't cycle them out any more. Tried resetting power to fridge and also put in new water filter. Got the fridge new with our home in october 2017 and already having issues.

Tried looking online on how to enter diagnostics mode but could not find any info. Anything i can try to figure out what i need to replace? before having to call out a repair company on my dime.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
Hi,

I'll our ask our other tech bigbuck if he has the tech. data sheet for your model.

Hold tight, he's usually here soon.

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona

Dyablo

Premium Member
Joined
Apr 7, 2019
Messages
7
Location
Buckeye, Az
thanks guys, so i ran test 44 and it looks like "Switch faulty or motor (Time out = 20 seconds)" is the result. it won't harvest ice.

safe to say the ice maker thing needs to be replaced?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
Yes, you are exactly right.:)

Let us know how it goes after you replace it.

Jake
 

Dyablo

Premium Member
Joined
Apr 7, 2019
Messages
7
Location
Buckeye, Az
well new part arrived and replaced. still won't make ice keeps coming back with the same result: test 44 -"Switch faulty or motor (Time out = 20 seconds)"

it does not try to even move the arm or tray. does not fill with water either. now I'm not hearing the end of it from the wife. :)
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
Where did you get the new ice maker from?

Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
Unplug the refrigerator for 5 minutes, then plug it in, and give it 24 hours to start making ice.

Jake
 

Dyablo

Premium Member
Joined
Apr 7, 2019
Messages
7
Location
Buckeye, Az
Didn’t work. I’ll note that when I removed the old ice marker unit the ice cubes that were there were not full size. Like it didn’t fill with water all the way the last time it worked.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
Ok,

I just remembered something, lots of members have found frayed and broken wires causing the ice maker/and or auger motor to be dead. Remove your bottom kickplate grille, Remove the black wire harness loom too, broken wires can be underneath it.

Another member was having a similar problem here: FIXED: GSF26C4EXY02 Whirlpool Gold Ice Maker Problem Look at his post #6 he found frayed and broken wires underneath the freezer door, remove your kickplate and check for that first.

Here's another one with the same thing about the frayed and broken wires: FIXED: 106.51173310 Kenmore elite ice maker not working - no led light

Here's another: FIXED: Whirlpool WSF26C2EXF01 Door Icemaker Not Working

Let us know what you find.

Jake
 

Dyablo

Premium Member
Joined
Apr 7, 2019
Messages
7
Location
Buckeye, Az
Jake, took a look at the wire loom. And it did have 3 wires broken where the wires bend when opening and closing door.

Repaired them, now to see if ice reruns.

Thanks
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
it did have 3 wires broken where the wires bend when opening and closing door.
BINGO.:)

Damn, my memory isn't as good as it once was or I would of told you to check that first.:)

Jake
 

Dyablo

Premium Member
Joined
Apr 7, 2019
Messages
7
Location
Buckeye, Az
regret to inform we still don't have ice. tray will harvest in diagnostics mode. But it does not appear the water valve is not opening. disconnected both water lines down at the kick plate and the bigger one will put out water if using the dispenser regularly. Once in process 45 no hose will put out water when pressing dispenser.

chances that the valve got messed up at the exact same time the 3 wires got cut down at the door?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
chances that the valve got messed up at the exact same time the 3 wires got cut down at the door?
Yes, possibly shorted it out.

Put your multimeter probes in the electrical connector that goes to the single water inlet valve, then Run service test #45- Ice Maker Water Fill Test, and see if your meter says 120 volts. Do the same on the ice maker solenoid side of the dual water inlet valve and see if you get 120 volts.

Here's the single water inlet valve for your model:
WPW10238100 Valve


Here's the dual water inlet valve for your model:
Water Inlet Valve WPW10341320


Let us know what you find.

Jake
 

elgreco

Premium Member
Joined
Nov 16, 2019
Messages
4
Location
houston, TX
Hello

I also have this model but my problem is slightly different. Its producing ice but for some reason its putting some ice cubes in the lip area above the ice bin door, very strange, and it makes some very loud noises after i manually remove those cubes from that area. See photos below. I assume it must be the twist tray bent or something and its not allowing the cubes to drop in the bin. I saw your post above on the diagnostics and will try it tomorrow. Any ideas what would cause this? I assume its the twist tray or the ice maker itself is malfunctioning..have you seen anything like this before?
 

Attachments

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
Overtime the twist tray can get hard water deposits on it and not release the cubes properly, if at all at times.

You will need to replace the ice maker, as they don't sell just the ice tray separately.

I posted the link to your ice maker in post #4 above.

Jake
 

elgreco

Premium Member
Joined
Nov 16, 2019
Messages
4
Location
houston, TX
Thanks for reply. I ordered the ice maker. In the interim, today I found the clip that hold the hose on the bottom of the tray in the bin and the hose hanging. Is this the fill hose or for something else? Don't see any holes in the piece that is attached to the hose or any holes in the bottom of the tray to allow water in? I kind of reattached it to the little tab on one side of the tray but the other side seems to be broken off. Will this keep it from making ice or not?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
104,368
Location
McMullen Valley, Arizona
That's not the hose under the ice tray, that's the thermistor that senses the ice tray temperature to dump the ice.

Look here:



Jake
 
Top