• Please note, some of the links on our site are affiliate links (Learn More)

WRT311FZDW Whirlpool fridge cold but freezer not cold

mountainbiker33

Premium Member
Joined
Jul 23, 2014
Messages
303
Location
Valparaiso, Indiana
Model Number
WRT311FZDW
Brand
Whirlpool
Age
6-10 years
This fridge has been running at my shop for 12 days. It started out great but has slowly warmed up both in the fridge and freezer. The freezer was logging in at -11degrees the first day and has hit as high as 40 but was at +11 today. The fridge has not gone over 42 but mostly stays in the mid 30s. There is almost zero frost pattern (I only checked once today)-no frost at all. The customer stated that it would behave this way but then eventually go back to normal. I am kind of thinking it could be a thermostat. I don't think this fridge has a thermistor. Both fans are running though I have not Ohmed them out. The compressor is quiet but running. Am I on the right track or is this a case of a leak?

UPDATE: I noticed the compressor turned off but the fans were still running. I think there might be an overload issue. Any thoughts?
 
Last edited:

Dan O.

Appliance Tech
Staff member
Joined
Oct 9, 2004
Messages
5,459
Location
Ontario, Canada
If the compressor IS running and has been for at least 15-20 minutes but no frost is developing on the evaporator, there is a refrigeration system problem. Maybe an intermittent internal compressor problem or a slim chance of a restriction however, it would be very uncommon to go away of its own.

mountainbiker33 said:
I noticed the compressor turned off but the fans were still running.

If the compressor is NOT running, it wont develop frosting.

Someone needs to clarify exactly what is or is not happening when the problem is present.

I think there might be an overload issue. Any thoughts?

Sure. When the compressor was NOT running, did anyone confirm if power was still going to its relay?

Dan O.
 
Top