• Please note, some of the links on our site are affiliate links (Learn More)

FIXED WRV986FDEM01 Whirlpool French door refrigerator issues, Sometimes it won't dispense ice or water, sometimes the lights don't work

Status
Not open for further replies.

kwlincoln

Member
Joined
Jul 12, 2021
Messages
1
Location
Houston, TX
I just found this thread trying to figure out my problem and realized I'm not alone!! I hope some of you are donating to Jake if that's possible. He deserves it.

WRV986FDEM01 for me too

Here's my problem... Lights always work. LED and temperature control panel on top of the drawer always work. Problems started when the water and ice dispenser intermittently stopped working. So would the ice maker. Then intermittently the fridge would stop cooling. I would get the clicking noise on the back / bottom. If I unplugged it for about a minute and plug it back in, everything will start working again. For a few days. If I hear the clicking, I have to unplug and re-plug it back in. Seems like one of the boards is bad but not sure which. I have a Fluke I can test if I'm smart enough to know what to test to determine. Does the fridge have to be malfunctioning at the time to test which board is bad?

Thanks in advance for help. I promise to post again to let you know what I found to find and fix my problem as many people don't follow up and I don't see what actually fixed their issue.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,294
Location
Redmond, Oregon
Hi,

Does your Temperature control Pantry drawer inside the refrigerator section no longer have a display? Is the display out?

Here's a service bulletin about this problem: https://drive.google.com/open?id=1OUD3L2YYjwGY48xB2u1jH-LMZXwtUl4a

Disconnect it and see if everything starts working properly again.

Here's the Pantry UI control board for your model:

If the Pantry display is fine and when you disconnected nothing changed, then you will need a MAIN new control board to fix it.

Here's the MAIN control board for your model you can order:
whirlpool-cntrl-elec-wpw10675033-ap6023728_01_m.jpg


Here's the video:


Jake
 

KPN

Premium Member
Joined
Jul 19, 2021
Messages
2
Location
Frisco, TX
I am in the same boat with a WRV986FDEM01. I've experienced the stop cooling/clicking noise issue several times. Powering off for about 15-30 minutes always clears that issue. Never had any issue with lights, door alarm, etc. The pantry UI works and inspection shows no sign of damage. My issue is that my freezer ice maker won't make ice. Specifically, I can hear it cycle periodically and even sound like it is trying to refill, but the ice maker gets no water. I can manually fill the ice maker and it will dump during the next cycle. I first had this issue last summer/fall, but then it cleared up and started working for several months. But it's now back to not making ice again. Before I go buy a replacement control board, I would appreciate the expert opinion on whether that is the likely culprit, or something else.

Thanks!!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,294
Location
Redmond, Oregon
Sounds like possibly the fill tube heater is not working, thus the fill tube has a ice clog in it.

I'm attaching your tech. data sheet below.

On Page 1 look under--->Control Board Troubleshooting--->To ENTER SERVICE DIAGNOSTICS Mode

Do Service Test - 19 Ice Maker Fill Tube Heater Status

--->Control the Ice Maker Fill Tube Heater by selecting SW3 (toggle between ON and OFF) (01 = ON, 02 = OFF).

Toggle it to 01 which is ON, then remove the freezer ice maker and feel if the fill tube heater is warm.

Jake
 

Attachments

  • tech-sheet-W10849496-RevA.pdf
    589.9 KB · Views: 82

KPN

Premium Member
Joined
Jul 19, 2021
Messages
2
Location
Frisco, TX
Thanks! I didn't even realize the bottom ice maker had a fill tube heater. In any event, I ran diagnostic #19 and let the heater run for about 15 mins. The freezer ice maker has now made about 4-5 cycles of ice since that time. :)

I did experience the cycle noises when I took the system out of diagnostic mode, and the compressor didn't start up. I had to unplug it for about 5 minutes and then plug back in to get the cooling to start again. I haven't had that issue in a few months. :wall:
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,294
Location
Redmond, Oregon
Ok, then replacing the main control board should fix all these issues on yours too.:)

I posted the link to your main control board in post #22 above.

Jake
 

KateM

Premium Member
Joined
May 18, 2022
Messages
2
Location
Memphis, TN
I also have a WRV986FDEM01 that had the lights and in-door ice maker go out. Thanks to these threads, I was able to pretty quickly diagnose the pantry door control panel. It's currently unplugged and everything is working again. I don't use this pantry control board, so is there a reason that it should be replaced or can I just leave it disconnected and be fine?
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,294
Location
Redmond, Oregon

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
130,294
Location
Redmond, Oregon
Anytime!

Jake
 
Status
Not open for further replies.
Top