• Please note, some of the links on our site are affiliate links (Learn More)

FIXED WRV986FDEM01 Whirlpool Refrigerator occasionally stops cooling

ryan3417

Premium Member
Joined
Mar 19, 2020
Messages
8
Location
Georgia
Model Number
WRV986FDEM01
Brand
Whirlpool
Age
1-5 years
Hello,

I have the Whirlpool version of this fridge (WRV986FDEM01). Its about 3 years old. I am having the same symptoms as (@user21). Noticed unit was not cooling as good as it should be over the last couple days and then the other day all cooling stopped, interior lights stopped working, compressor nor any fans were running. Only the front panel lights would work but no water or ice would dispense.

If i unplug the fridge and plug it back in after a minute or so everything starts back up (condenser fan, compressor, FC evap fan, RC evap fan, etc). Its been running since last night and temps seem to be where they should be. I ran through all the diagnostics last night and everything passed (i have the tech sheet). But I suspect the unit will die again again in the next day or so. I have confirmed 120v and 12v into and out of the main power board while the unit was plugged in but not working.

Wanted to confirm with original poster (or a tech or anyone on this thread who had similar symptoms) if the main control board was the culprit. I heard that the pantry (left pull out door) wire harness and/or the pantry circuit board could be a fail point as well that is causing the entire machine to shut down like this.

Thanks
Ryan
Atlanta, GA
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,789
Location
McMullen Valley, Arizona
Hi Ryan,

Disconnect it and see if everything starts working properly again. If so, check your wire harness first to see if you notice a short in it, if no short then the problem is the Pantry UI control board.

Here's the wire harness to it:

Here's the Pantry UI control board for your model:

Jake
 

ryan3417

Premium Member
Joined
Mar 19, 2020
Messages
8
Location
Georgia
Hi Jake,

So the unit is currently running and has been since last night. The pantry UI board has been connected since start-up last night.

That being said, would your recommendation then be to let the unit run and if and when it loses power to unplug the pantry UI board and see if the unit comes back to life? Would running a pantry UI board diagnostic help?

Thanks for your help.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,789
Location
McMullen Valley, Arizona
That being said, would your recommendation then be to let the unit run and if and when it loses power to unplug the pantry UI board and see if the unit comes back to life? Would running a pantry UI board diagnostic help?
Yes and Yes.:)

Let us know what happens Ryan.

Jake
 

ryan3417

Premium Member
Joined
Mar 19, 2020
Messages
8
Location
Georgia
Jake,

So up to this point the fridge and freezer compartments had been holding temp just fine. However, just now i went to check their temps and fridge was at 38 degrees (and blowing cold air into the fridge, all good) but the freezer evap fan was not on at all and freezer compartment temp was measuring 45 degrees. It has been measuring 0 or slightly below since I restarted the fridge Wednesday night. So i unplugged the pantry UI board (even though this wasn't a full system "crash") but no change..freezer still silent. I then went into the temperature controls on the front dispenser panel and changed the freezer temp from 0 down to -5 and i suddenly heard the freezers evap fan turn on and its now blowing cold air into the freezer once more. I returned the temp back to zero and its still blowing. I also ran a diagnostic on the freezer compartment thermistor and it passed the test.

Thoughts on next steps?
 
Last edited:

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,789
Location
McMullen Valley, Arizona
Let it run for a few days and see what happens.

If running it without the UI Pantry Board connected does not solve it then its likely the control board you will need to replace.

Here's a similar thread and it uses the exact same control board yours does:
Here's the control board for your model:
Main Control Board WPW10675033


Jake
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,789
Location
McMullen Valley, Arizona
Ok Ryan, sounds good.

Jake
 

ryan3417

Premium Member
Joined
Mar 19, 2020
Messages
8
Location
Georgia
Hi Jake,

So the fridge and freezer has been cooling without issue since my last message. The pantry drawer board is still disconnected. So I suspect that board was the problem. I may or may not replace it at some point in the future.

Thanks again for your help!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
107,789
Location
McMullen Valley, Arizona
Ok Ryan, glad to hear its still doing great after you disconnected that UI Pantry Board, it was definity causing it.:)

Yes, you can leave it disconnected or order and replace the UI Pantry Board.

Thanks for the update!

Jake
 
Top