FIXED WRX988SIBM00 Extremely slow water dispenser

Askeptic

Premium Member
Joined
Sep 1, 2015
Messages
2
Location
United States
Model Number
WRX988SIBM00
Brand
Whirlpool
Age
Less than 1 year
Hello,

I purchased a Whirlpool Gold WRX988SIBM00 Refrigerator and am experiencing extremely slow water dispense speed when using a filter. If I remove the filter, the water comes out extremely fast. (along with loud noises on the top front corner where I am guessing a water pump may be located).

To summarize "slow", with the filter in, It takes ~22 seconds to dispense 1 cup of water. I am using the water filter that came packaged with the refrigerator. This Refrigerator is ~6 months old and has always been this slow. I use the water function daily.

Could this be a bad filter and/or Refrigerator?
Is this level of "slow" normal for this model?
Anything I can do to improve water flow?

Thanks!
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,782
Location
Murray, Utah 84107, United States
Could be the filter or filter housing. Try a different filter. If that doesn't work, call for warranty service. Any repair attempts and you risk losing your warranty.
 

Askeptic

Premium Member
Joined
Sep 1, 2015
Messages
2
Location
United States
Could be the filter or filter housing. Try a different filter. If that doesn't work, call for warranty service. Any repair attempts and you risk losing your warranty.
Thank you for this information. I removed my PUR water filter that shipped with the Frig, and replaced it with an EveryDrop water filter EDR2RXD1. The water is MUCH faster when dispensing now.

For comparison... where it use to take me ~22 seconds for a cup of water, it now takes me ~8 seconds. To be fair though, I think the PUR filtered it slightly better ... but no way could I go back to those slow speeds.

Thank you.
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,782
Location
Murray, Utah 84107, United States
22 seconds for a cup of water is past my patients level for sure! Glad you got it solved!
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,195
Location
McMullen Valley, Arizona
That's very interesting, I'm having the same issue with my fairly new refrigerator.

When I moved from Oregon to Arizona in 2014, I needed a new refrigerator myself, I went to Sears in Goodyear, Arizona and bought this one: 106.51122210 Kenmore 25 cu. ft. Side-by-Side Refrigerator - White

Kenmore 106 models are made by Whirlpool.:)

And mine has been slow to fill too, but I rarely use the water dispenser because I get Sparkletts bottled water delivered, and have a 5 gal water cooler.

I just looked up my model number and see its been Substituted to part number EveryDrop EDR1RXD1

I just purchased it from that link, I'm interested in seeing if this Everydrop water filter increases my fill time as well. I needed a new water filter anyways, its been 12 months since I replaced it.

Mine was about 22 seconds as well for fill time.

Jake
 

rickgburton

Appliance Tech - Moderator
Staff member
Joined
Jul 11, 2006
Messages
34,782
Location
Murray, Utah 84107, United States
Jake, I'll pencil you in for a service call. Friday morning good for you?.....6c2ba386.x120.gif
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
102,195
Location
McMullen Valley, Arizona
LOL, yes perfect Rick, I'll have the coffee and donuts ready!

Jake
 
Top