• Please note, some of the links on our site are affiliate links (Learn More)

Yet another kenmore dryer (Laundry center) problem

Seal

Premium Member
Joined
Apr 2, 2005
Messages
7
Location
, ,
imported post

Please help, I have a Kenmore Laundry center 417.99185120 (W25233956), unfortunately the dryer function recently stopped working. You can select the type of cycle but when you press the start button you hear two beeps letting you know that the command was not accepted. If you press stop it also beeps twice but if you press cancel the display clears. I have checked the door sensor which seems to be fine. I have also taken the front apart and cleaned away any lint.


Any advice would be greatly appreciated.
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,285
Location
McMullen Valley, Arizona
imported post

Hi,

I don't see too many electronic Kenmore/Frigidaire style laundry centers out there, yours must be a older model? The 417 model is made by Frigidaire.

But first i would try to turn the breaker off or unplug it for 60 seconds to see if that resets everything, if that does not fix it, i would say you have a control board or touch panel problem, both are very expensive parts, im sorry to say.

Did it dry well before? Or did you notice it started taking longer to dry heavy loads? If so, i would check the vent for good air flow.

Jake
 

Seal

Premium Member
Joined
Apr 2, 2005
Messages
7
Location
, ,
imported post

Thanks very much for your quick reply.

I did have the breaker off for quite some time while I checked inside all the duct work etc. for lint. I had wondered if it needed resetting. We got it in 1993 so I guess it doesn't owe us anything ;)but yes it did work well. We did have to clean out the vent whenever we noticed it taking longer to dry. I wasn't sure if it would be the control panel as all of the other buttons seem to work. We were using it, finished a load and then when we tried the next one it didn't work. It was as if the door wasn't closed and the safety feature wouldn't allow it to run but after checking the door sensor with a meter, it appears to be fine. I have replaced belts and the plastic drum inside the airventbefore.

Thanks again
 

Jake

Appliance Tech - Admin
Staff member
Joined
Aug 24, 2004
Messages
105,285
Location
McMullen Valley, Arizona
imported post

Your welcome,

Good Luck,

Jake
 
Top