• Please note, some of the links on our site are affiliate links (Learn More)

York Diamond 80 (P4HUB16L06401A) Furnace stopped blowing air

Bonz2020

Premium Member
Joined
Sep 6, 2020
Messages
8
Location
Southern California
Model Number
P4HUB16L06401A
Age
More than 10 years
Hello and happy new year.
Got another one, if anyone responds responds, thank you in advance.
I have a York Diamond 80 (P4HUB16L06401A) furnace that has suddenly stopped blowing air, as it was about to begin to. There may have been a minor burning smell but the furnace is up in the attic, so hard me to believe the smell came from the attic. Stranger things have been seen thou.
The start up sequence I hear is; the inducer motor coming on, igniter, followed by gas and flame. That process works. But the blower motor never kicks in. The furnace shuts down after a minute or so. I presume because the sensors get too hot.
I opened the furnace. The control board's motherboard may have a minute burnt mark on it. Found the wiring diagram for the control board and it looks like I could probe directly onto the blower motor connector. Do I trick the furnace door by keeping the switch pressed with some tape? Or should I could simply replace the board, since it could be a bit charred, and bypass second guessing the timing?...Meaning, I am not sure what should be coming through that connector. Is it 5, 10, 15 volts more, less?? Any ideas?
Or is it more likely to be the blower motor? (No squeaks or issues with it before)
Or the capacitor?
Any guidance on how to troubleshoot this one would be very welcomed. Otherwise I believe my best bet is to start replacing components, starting with the Capacitor, then control board and then motor.
All the best
 
Top