• Please note, some of the links on our site are affiliate links (Learn More)

ZDP304NPSS GE Monogram Dual-Fuel Range: Won't heat past 375F & won't Broil

sciuridae

Member
Joined
Jun 1, 2022
Messages
1
Location
TORONTO, ON
Model Number
ZDP304N
Brand
GE
Age
More than 10 years
Hi, I have a GE Monogram Dual-Fuel 30" Range with 4 Burners (ZDP304NPSS). The oven is is electric and the burners are natural gas. https://appliances.monogram.com/us/specs/ZDP304NPSS

It is part of the family of ranges that includes:
ZDP304N – 4 burners (my Range)
ZDP366N – 6 burners
ZDP364ND – 4 burners and griddle
ZDP364NR – 4 burners and grill
ZDP484NG – 4 burners, grill and griddle
ZDP486ND – 6 burners and griddle
ZDP486NR – 6 burners and grill

I had an a problem with the range not allowing itself to pre-heat past 375° F. If, for example, in Bake mode the oven was set to 400°, as the temperature approached ~375° the oven would suddenly shut off without generating any error code.

I replaced the Oven's Temperature Sensor based on some feedback on a different repair site. The sensor replacement did not resolve the problem, and I tried a Self Clean Cycle simply to see if it would succeed given the temperatures involved. Surprisingly, the Self Clean cycle completed successfully and also magically the problem did not reoccur following the cleaning. I tested the old Temperature Sensor with a DMM and it was not defective so my part change hadn't solved anything. I counted myself lucky and forgot about it for almost a year until the problem returned 9-10 months later.

Now that the lack of preheating past 375° problem is back I have done bit more testing and also have noted that the Broil (Hi/Lo) no longer starts at all. We rarely Broil so I cannot say the broil issue (1) also existed before and was similarly temporarily resolved for a few months, or (2) existed before and has continued to be an issue unbeknown to us, or (3) is an entirely new problem that we just noted.

When pre-heating the oven, all the heat seems to come from the top of the oven and only reflected heat from the bottom.

I have never seen any faults/errors show up when the oven malfunctions, either when trying to engage the Broil modes, or even when the oven cuts out suddenly at ~375°.
Multiple cycles of tests in Factory Mode have passed without triggering any Fault Codes, and there are no Failure Codes stored in nonvolatile memory, even following triggering a cutout, and then immediately re-checking the memory in Factory Mode.

I have not re-tested a Self Clean Cycle but I suspect that it would still work, but am reluctant to initiate it at this point without guidance. Also note that when trying to engage the Broil modes, there is nothing on the display, nor any sounds or anything from the oven, almost as if the functions are not available.

I am hoping that the combination of the symptoms coupled with a lack of any Fault Codes may provide some insight to someone with knowledge of this range. Would love to know how to further narrow this down and identify the offending components. The oven has been great and was purchased new over 10 years ago. The components are expensive and some are difficult to get in a timely manner so I want to avoid replacing too many without a plan.

Thanks for any help.
 

Attachments

  • ZDP304N Technical Manual.pdf
    3.1 MB · Views: 55
  • ZDP304N Installation.pdf
    3 MB · Views: 32
  • ZDP304N Owners Manual.pdf
    3.7 MB · Views: 35
If you feel that you have benefited from this site, and would like to show your appreciation.
Top